summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 12 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 8c96e74d..f0d83589 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1581,17 +1581,23 @@ AS_CASE(["${exec_prefix}"],
['NONE'|'${prefix}'],
[:],
[*],
- [can_relocate=no])
+ [
+ can_relocate=no
+ # If the user said --enable-relocation but we can't do it, error out
+ AS_IF([test "x$enable_relocation" = xyes],
+ [AC_MSG_ERROR([Relocatable pkg-config metadata requires --exec-prefix='\${prefix}', not ${exec_prefix}])])
+ ])
AS_CASE(["${libdir}"],
['${prefix}/lib'|'${prefix}/lib64'|'${exec_prefix}/lib'|'${exec_prefix}/lib64'],
[:],
[*],
- [can_relocate=no])
-
-# If the user said --enable-relocation but we can't do it, error out
-AS_IF([test "x$can_relocate" = xno && test "x$enable_relocation" = xyes],
- [AC_MSG_ERROR([Relocatable pkg-config metadata requires --exec-prefix='\${prefix}' and the default libdir])])
+ [
+ can_relocate=no
+ # If the user said --enable-relocation but we can't do it, error out
+ AS_IF([test "x$enable_relocation" = xyes],
+ [AC_MSG_ERROR([Relocatable pkg-config metadata requires default libdir, not ${libdir}])])
+ ])
# By default, on Windows we are relocatable if possible
AS_IF([test "x$enable_relocation" = xauto && test "x$dbus_win" = xyes],