summaryrefslogtreecommitdiff
path: root/bus/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'bus/meson.build')
-rw-r--r--bus/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/bus/meson.build b/bus/meson.build
index 06e293b8..1aaaf48d 100644
--- a/bus/meson.build
+++ b/bus/meson.build
@@ -184,6 +184,19 @@ if platform_unix and use_traditional_activation
)
endif
+install_emptydirs += [
+ get_option('datadir') / 'dbus-1' / 'session.d',
+ get_option('datadir') / 'dbus-1' / 'services',
+]
+
+if platform_unix
+ install_emptydirs += [
+ get_option('localstatedir') / 'run' / 'dbus',
+ get_option('datadir') / 'dbus-1' / 'system.d',
+ get_option('datadir') / 'dbus-1' / 'system-services',
+ ]
+endif
+
if use_systemd
install_symlinks += [
{