summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2019-04-17 13:33:06 +0000
committerSimon McVittie <smcv@collabora.com>2019-04-17 13:33:06 +0000
commitfd0c19d6d87419371280b5cd511ea41e45b7ece5 (patch)
treece0e2abbf60ba059c647656d401f7ae5a9f91dd9 /test/Makefile.am
parent812678e595592e33e444fb9c92dfbe645fd83980 (diff)
parent94b5b236aa0743bacb2139c62d5a6e0143845634 (diff)
downloaddbus-fd0c19d6d87419371280b5cd511ea41e45b7ece5.tar.gz
Merge branch 'disable-traditional-activation' into 'master'
Configure option to disable traditional activation See merge request dbus/dbus!107
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 95a4592f..27d19460 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -67,7 +67,6 @@ uninstallable_test_programs =
## break-loader removed for now
## these binaries are used in tests but are not themselves tests
TEST_BINARIES = \
- test-spawn \
test-exit \
test-names \
test-privserver \
@@ -76,7 +75,13 @@ TEST_BINARIES = \
$(NULL)
if !DBUS_WINCE
+if ENABLE_TRADITIONAL_ACTIVATION
uninstallable_test_programs += test-spawn-oom
+endif ENABLE_TRADITIONAL_ACTIVATION
+endif !DBUS_WINCE
+
+if ENABLE_TRADITIONAL_ACTIVATION
+TEST_BINARIES += test-spawn
endif
uninstallable_test_programs += \
@@ -90,11 +95,13 @@ uninstallable_test_programs += \
$(NULL)
if DBUS_UNIX
+if ENABLE_TRADITIONAL_ACTIVATION
uninstallable_test_programs += test-bus-launch-helper-oom
uninstallable_test_programs += test-bus-system
# this is used by the tests but is not, itself, a test
TEST_BINARIES += dbus-daemon-launch-helper-for-tests
-endif
+endif ENABLE_TRADITIONAL_ACTIVATION
+endif DBUS_UNIX
noinst_PROGRAMS += $(uninstallable_test_programs)
TESTS += $(uninstallable_test_programs)
@@ -120,10 +127,13 @@ test_privserver_LDADD = libdbus-testutils.la
test_shell_service_LDADD = libdbus-testutils.la
test_shell_SOURCES = shell-test.c
test_shell_LDADD = libdbus-testutils.la
+
+if ENABLE_TRADITIONAL_ACTIVATION
test_spawn_SOURCES = spawn-test.c
test_spawn_LDADD = $(top_builddir)/dbus/libdbus-internal.la
test_spawn_oom_SOURCES = internals/spawn-oom.c
test_spawn_oom_LDADD = libdbus-testutils.la
+endif
test_assertions_SOURCES = internals/assertions.c
test_assertions_LDADD = libdbus-testutils.la $(GLIB_LIBS)