summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2017-11-21 13:36:10 +0000
committerSimon McVittie <smcv@collabora.com>2017-11-24 12:17:35 +0000
commitac6c4d384d83c2e39a4f4156ef11cadcfbfa44f6 (patch)
tree47b45793673dac22a3b45adcc9884ef528ccd85f /test/Makefile.am
parenta9aef9b378b05f5a7f0ce55b89684990d5447df8 (diff)
downloaddbus-ac6c4d384d83c2e39a4f4156ef11cadcfbfa44f6.tar.gz
Add a targeted test for OOM during _dbus_server_new_for_tcp_socket()
This also covers _dbus_server_new_for_socket(), which is one of the worse places in terms of complexity of the error-unwinding path (3 labels). Signed-off-by: Simon McVittie <smcv@collabora.com> Reviewed-by: Philip Withnall <withnall@endlessm.com> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=89104
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index a748b10a..57342034 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -105,6 +105,9 @@ test_printf_LDADD = $(top_builddir)/dbus/libdbus-internal.la
test_refs_SOURCES = internals/refs.c
test_refs_LDADD = libdbus-testutils.la $(GLIB_LIBS)
+test_server_oom_SOURCES = internals/server-oom.c
+test_server_oom_LDADD = libdbus-testutils.la $(GLIB_LIBS)
+
test_syslog_SOURCES = internals/syslog.c
test_syslog_LDADD = libdbus-testutils.la $(GLIB_LIBS)
@@ -164,6 +167,7 @@ installable_tests += \
test-marshal \
test-refs \
test-relay \
+ test-server-oom \
test-syntax \
test-syslog \
test-uid-permissions \