summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2015-01-26 19:10:11 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2015-02-03 16:19:08 +0000
commit98ae1149adf23acd0aae9611f93ac2250ac37bd7 (patch)
treed0c858300e29194cef3734187dea5e38db558864 /test/Makefile.am
parent6a49ced2dd3a1e3b161c677deb72d98674a9069d (diff)
downloaddbus-98ae1149adf23acd0aae9611f93ac2250ac37bd7.tar.gz
Add a test for uid-controlled permissions
This is technical debt from mitigating CVE-2014-8148, which should really have had a regression test at the time. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=88810 Reviewed-by: Philip Withnall
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index ec761605..75e70d29 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -162,6 +162,7 @@ installable_tests += \
test-relay \
test-syntax \
test-syslog \
+ test-uid-permissions \
$(NULL)
installable_manual_tests += \
manual-authz \
@@ -240,6 +241,15 @@ test_syntax_LDADD = \
$(GLIB_LIBS) \
$(NULL)
+test_uid_permissions_SOURCES = \
+ uid-permissions.c \
+ $(NULL)
+test_uid_permissions_CPPFLAGS = $(testutils_shared_if_possible_cppflags)
+test_uid_permissions_LDADD = \
+ $(testutils_shared_if_possible_libs) \
+ $(GLIB_LIBS) \
+ $(NULL)
+
if DBUS_ENABLE_MODULAR_TESTS
TESTS += $(installable_tests)
installcheck_tests += $(installable_tests)
@@ -276,6 +286,7 @@ in_data = \
data/valid-config-files/debug-allow-all.conf.in \
data/valid-config-files/finite-timeout.conf.in \
data/valid-config-files/incoming-limit.conf.in \
+ data/valid-config-files/multi-user.conf.in \
data/invalid-service-files-system/org.freedesktop.DBus.TestSuiteNoExec.service.in \
data/invalid-service-files-system/org.freedesktop.DBus.TestSuiteNoService.service.in \
data/invalid-service-files-system/org.freedesktop.DBus.TestSuiteNoUser.service.in \