summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2015-02-03 14:45:35 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2015-02-04 17:15:36 +0000
commit94610d7de6c9a00729a53c4bc9f6517c62696732 (patch)
tree5ae63202bb93d0f500b5194cd13942fc6a3e4f51 /test/Makefile.am
parent1a28f82926c31ae17b8688bdeb6d68f29d628592 (diff)
downloaddbus-94610d7de6c9a00729a53c4bc9f6517c62696732.tar.gz
Add a common test_init() for GLib tests which prevents hanging forever
Bug: https://bugs.freedesktop.org/show_bug.cgi?id=46787 Reviewed-by: Philip Withnall <philip.withnall@collabora.co.uk>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 6d721856..ca2fb9db 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -242,7 +242,7 @@ test_sd_activation_LDADD = \
test_marshal_SOURCES = marshal.c
test_marshal_LDADD = \
- $(top_builddir)/dbus/libdbus-1.la \
+ $(testutils_shared_if_possible_libs) \
$(GLIB_LIBS) \
$(NULL)
@@ -257,7 +257,7 @@ test_monitor_LDADD = \
test_syntax_SOURCES = syntax.c
test_syntax_LDADD = \
- $(top_builddir)/dbus/libdbus-1.la \
+ $(testutils_shared_if_possible_libs) \
$(GLIB_LIBS) \
$(NULL)