summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorAdrian Szyndela <adrian.s@samsung.com>2019-04-25 09:35:59 +0200
committerAdrian Szyndela <adrian.s@samsung.com>2019-05-14 10:31:12 +0200
commit7b7c57243482af1a4ace21351b2cdf988676575d (patch)
treebab2b5eac66ff3544d2e90e2066e883d438dac32 /test/Makefile.am
parent055ff9e64a65931cbd2b94f24ea46bf3750d0b8e (diff)
downloaddbus-7b7c57243482af1a4ace21351b2cdf988676575d.tar.gz
test: send_destination(_prefix) tests
This adds tests for mostly "send_destination_prefix" cases and some "send_destination" cases. The general test case is: - addressed recipient is running and owns a name; - a message is sent to the name owner; - the response is checked for allow/deny (method return/error). Each test case is executed both for primary and queued ownership. The tests include: - checking send allow/deny for names and namespaces, including nesting; - checking send allow/deny for neighbour names; - checking send allow/deny for names/namespaces+interface+member. Signed-off-by: Adrian Szyndela <adrian.s@samsung.com> Change-Id: If5fcada01601355e7aadefadad79c0b24f8c397f
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 559590b2..fd16381c 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -604,6 +604,7 @@ in_data = \
data/valid-config-files/max-replies-per-connection.conf.in \
data/valid-config-files/multi-user.conf.in \
data/valid-config-files/pending-fd-timeout.conf.in \
+ data/valid-config-files/send-destination-prefix-rules.conf.in \
data/valid-config-files/systemd-activation.conf.in \
data/valid-config-files/tmp-session.conf.in \
data/valid-config-files-system/tmp-session-like-system.conf.in \