summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2017-11-27 15:51:15 +0000
committerSimon McVittie <smcv@collabora.com>2018-01-11 18:34:10 +0000
commit6f8d82009dae34562bb722a06f8a159e0230421e (patch)
tree114afe1e7a84f3505c2a7e6f176cfbec8347634b /test/Makefile.am
parentcfd73beacf16a290cb153e9f6fa7c03719475295 (diff)
downloaddbus-6f8d82009dae34562bb722a06f8a159e0230421e.tar.gz
Add a test for header fields
Signed-off-by: Simon McVittie <smcv@collabora.com> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=100317 Reviewed-by: Philip Withnall <withnall@endlessm.com> Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 893b7387..feb84a65 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -161,6 +161,7 @@ installable_tests += \
test-dbus-daemon \
test-dbus-daemon-eavesdrop \
test-fdpass \
+ test-header-fields \
test-message \
test-monitor \
test-loopback \
@@ -324,6 +325,15 @@ test_dbus_daemon_eavesdrop_LDADD = \
$(GLIB_LIBS) \
$(NULL)
+test_header_fields_SOURCES = \
+ header-fields.c \
+ $(NULL)
+test_header_fields_LDADD = \
+ libdbus-testutils.la \
+ $(top_builddir)/dbus/libdbus-internal.la \
+ $(GLIB_LIBS) \
+ $(NULL)
+
if DBUS_UNIX
test_sd_activation_SOURCES = \
sd-activation.c \