summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2017-06-20 17:37:33 +0100
committerSimon McVittie <smcv@collabora.com>2017-12-11 15:50:31 +0000
commit3d2028dfe0d94247af67edcf680d38a99bcbc71b (patch)
tree15cc135f65d4b0ba6fa30159598515e94d44a61f /test/Makefile.am
parentb37fa3e8ca7891ad50d27eb004190c9111a3b19a (diff)
downloaddbus-3d2028dfe0d94247af67edcf680d38a99bcbc71b.tar.gz
test/containers: New test
So far it only exercises SupportedArguments. Signed-off-by: Simon McVittie <smcv@collabora.com> Reviewed-by: Philip Withnall <withnall@endlessm.com> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=101354
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 57342034..130f5600 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -181,6 +181,7 @@ installable_helpers += \
$(NULL)
installable_tests += \
+ test-containers \
test-sd-activation \
$(NULL)
@@ -286,6 +287,12 @@ test_apparmor_activation_LDADD = \
$(NULL)
endif
+test_containers_SOURCES = containers.c
+test_containers_LDADD = \
+ libdbus-testutils.la \
+ $(GLIB_LIBS) \
+ $(NULL)
+
test_corrupt_SOURCES = corrupt.c
test_corrupt_LDADD = \
libdbus-testutils.la \