summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2017-11-14 17:53:31 +0000
committerSimon McVittie <smcv@collabora.com>2017-11-15 12:12:43 +0000
commit3baad75ca94173f44bb65c941694ab7a765eeed6 (patch)
tree3ebd58cfc22b0f5e13bae4c5d6a5dc65f0ac69fe /test/Makefile.am
parentea43f3db48ad1ac01b47a2eab6b4567fbd968c45 (diff)
downloaddbus-3baad75ca94173f44bb65c941694ab7a765eeed6.tar.gz
test-bus*: Output TAP directly
Reviewed-by: Philip Withnall <withnall@endlessm.com> Signed-off-by: Simon McVittie <smcv@collabora.com> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=103601
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am12
1 files changed, 3 insertions, 9 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 2721a4a9..719e8653 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -73,20 +73,14 @@ TEST_BINARIES = \
## since they depend on stuff from this directory. We wrap some of them in a
## simple shell script to get TAP output.
-wrap_bus_tests = test-bus.sh
+TESTS += ../bus/test-bus$(EXEEXT)
if DBUS_UNIX
-wrap_bus_tests += test-bus-launch-helper.sh
-wrap_bus_tests += test-bus-system.sh
+TESTS += ../bus/test-bus-launch-helper$(EXEEXT)
+TESTS += ../bus/test-bus-system$(EXEEXT)
endif
-TESTS += $(wrap_bus_tests)
TESTS += ../dbus/test-dbus$(EXEEXT)
-CLEANFILES += $(wrap_bus_tests)
-
-$(wrap_bus_tests): test-bus%.sh: ../bus/test-bus%$(EXEEXT) tap-test.sh.in Makefile
- sed -e 's![@]RUN[@]!$<!' \
- < $(srcdir)/tap-test.sh.in > $@
else !DBUS_ENABLE_EMBEDDED_TESTS