summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2018-11-16 18:53:11 +0000
committerSimon McVittie <smcv@collabora.com>2018-12-03 17:42:48 +0000
commit1191262f5ebb881f9a07862f0b7b9176c502edc1 (patch)
tree58feb0c17af77a09d8474cca0c8fdb6833bc2851 /test/Makefile.am
parentebe5744375885542daadddd84b143a4414bae513 (diff)
downloaddbus-1191262f5ebb881f9a07862f0b7b9176c502edc1.tar.gz
Translate Python-based tests to C
This simplifies bootstrapping: now you don't have to build dbus, build dbus-python (with GLib), and use dbus-python to test dbus. It also avoids test failures when using facilities like AddressSanitizer. When libdbus is built with AddressSanitizer, but the system copies of Python and dbus-python were not, dbus-python will exit the Python interpreter on load, because libasan wasn't already initialized. The simplest way to avoid this is to not use Python: the scripts are not *that* hard to translate into C. Both of these tests happen to be conditionally compiled for Unix only. test_activation_forking() relies on code in TestSuiteForkingEchoService that calls fork(), which can only work on Unix; meanwhile, test_system_signals() tests the system bus configuration, which is only relevant to Unix because we don't support using dbus-daemon as a privilege boundary on Windows (and in any case D-Bus is not a Windows OS feature, so the system bus cannot be used to communicate with OS services like it can on most Linux systems). This is also a partial solution to <https://gitlab.freedesktop.org/dbus/dbus/issues/135>, by reducing the size of name-test/. For this to work, we need to build the test-service helper executable even if embedded tests are disabled. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index bc87446c..408cf668 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -64,7 +64,6 @@ TEST_BINARIES = \
test-exit \
test-names \
test-segfault \
- test-service \
test-shell-service \
$(NULL)
@@ -145,6 +144,7 @@ nobase_testexec_PROGRAMS =
nobase_testmeta_DATA =
installable_helpers = \
+ test-service \
test-sleep-forever \
$(NULL)
installable_tests = \