summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLuca Boccassi <bluca@debian.org>2023-03-20 01:40:20 +0000
committerSimon McVittie <smcv@collabora.com>2023-05-15 19:06:54 +0000
commit4364b9ebb3acef566a2c1955423426584147226e (patch)
treeafbef4a885ef77ca7c0adcaf0e8b87912fc8f10e /meson.build
parent1a74c43c0e545f41b6266713362c42748ee579e8 (diff)
downloaddbus-4364b9ebb3acef566a2c1955423426584147226e.tar.gz
Support /proc in _dbus_file_get_content
procfs has special semantics: most files are 0 size, only one read can be done on a file, and they are not larger than 4MB. Enhance _dbus_file_get_content() so that we can read files from /proc with it. Signed-off-by: Luca Boccassi <bluca@debian.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index df302a7d..e2cbc368 100644
--- a/meson.build
+++ b/meson.build
@@ -670,6 +670,7 @@ check_headers = [
'io.h',
'locale.h',
'linux/close_range.h',
+ 'linux/magic.h',
'locale.h',
'signal.h',
'syslog.h',
@@ -678,6 +679,7 @@ check_headers = [
'sys/resource.h',
'sys/syscall.h',
'sys/time.h',
+ 'sys/vfs.h',
'unistd.h',
'ws2tcpip.h',
]
@@ -753,6 +755,13 @@ config.set('HAVE_UNPCBID',
)
)
+config.set('HAVE_FSTATFS',
+ cc.has_function(
+ 'fstatfs',
+ prefix : '#include <sys/vfs.h>',
+ args: compile_args_c,
+ )
+)
###############################################################################
# Project options