summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPatrick Welche <prlw1@cam.ac.uk>2014-07-29 14:08:20 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2014-11-06 14:29:50 +0000
commitf26ade306c1d583897610c767a560e972d680f35 (patch)
tree42806a07a916e82b528fc8669689acd320bc2aea /configure.ac
parentfc2fa25a3f729a704ff4ae8e3c733b81eb7c0c75 (diff)
downloaddbus-f26ade306c1d583897610c767a560e972d680f35.tar.gz
Implement NetBSD credentials-passing with LOCAL_PEEREID
Bug: https://bugs.freedesktop.org/show_bug.cgi?id=69702 Reviewed-by: Simon McVittie <simon.mcvittie@collabora.co.uk> Reviewed-by: Alban Crequy <alban.crequy@collabora.co.uk> Tested-by: Patrick Welche <prlw1@cam.ac.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index de34d3e2..ae2c01ca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -818,6 +818,11 @@ if test x$dbus_have_struct_cmsgcred = xyes; then
AC_DEFINE(HAVE_CMSGCRED,1,[Have cmsgcred structure])
fi
+AC_CHECK_MEMBER([struct unpcbid.unp_pid],
+ [AC_DEFINE([HAVE_UNPCBID], 1, [Have unpcbid structure])],
+ [],
+ [[#include <sys/un.h>]])
+
AC_CHECK_FUNCS(getpeerucred getpeereid)
AC_CHECK_FUNCS(pipe2 accept4)