summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2022-02-25 16:06:59 +0000
committerSimon McVittie <smcv@collabora.com>2022-02-27 17:05:56 +0000
commitdaf362ee61170727be0ca5dec1cf39435485ad0c (patch)
treebdf3957cff88c33aa5e77fafa6ad21917730ba5b /configure.ac
parent71f74ee53094340118918ba384ac7165045075cf (diff)
downloaddbus-daf362ee61170727be0ca5dec1cf39435485ad0c.tar.gz
build: Opt out from using mingw-w64's replacement printf(), etc.
The Windows code in dbus is careful to use Windows-specific equivalents of the Standard C features that are not implemented by msvcrt.dll, so we don't need to substitute a Standard C printf implementation. This avoids compiler warnings/errors when gcc expects us to be using Microsoft printf syntax (`ms_printf` attribute), but newer versions of mingw-w64 expect us to be using GNU or Standard C printf syntax (`gnu_printf` attribute) as a result of `__USE_MINGW_ANSI_STDIO` being enabled by default if not otherwise specified. Resolves: https://gitlab.freedesktop.org/dbus/dbus/-/issues/380 Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 78f715b5..eb2314f2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1694,6 +1694,15 @@ AH_VERBATIM(_DARWIN_ENVIRON,
#endif
])
+AH_VERBATIM([USE_MINGW_ANSI_STDIO],
+[
+/* On Windows, we expect to be using msvcrt.dll-compatible printf
+ * (%I64u instead of %llu) unless otherwise specified */
+#ifndef __USE_MINGW_ANSI_STDIO
+# define __USE_MINGW_ANSI_STDIO 0
+#endif
+])
+
AC_ARG_ENABLE([stats],
[AS_HELP_STRING([--disable-stats],
[disable bus daemon usage statistics])],