summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2022-07-11 10:59:33 +0400
committerSimon McVittie <smcv@collabora.com>2022-07-13 20:36:13 +0100
commit95df73b4638b754a069e423ffe03041241b2de8c (patch)
tree7fda649ace64d0581c280e516f0a11c249e33ba3 /configure.ac
parentf0a4d9249078b5ce7f37aea254a4911e481ef584 (diff)
downloaddbus-95df73b4638b754a069e423ffe03041241b2de8c.tar.gz
cmake/autotools: remove HAVE_DIRFD/HAVE_DDFD
dirfd() is assumed to be present on Linux, dd_fd is never used. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 0 insertions, 35 deletions
diff --git a/configure.ac b/configure.ac
index 3b225a29..d72d8f7c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -647,41 +647,6 @@ if test "x$ac_cv_header_syslog_h" = "xyes"; then
AC_CHECK_DECLS([LOG_PERROR], [], [], [[#include <syslog.h>]])
fi
-AC_MSG_CHECKING(for dirfd)
-AC_LINK_IFELSE([AC_LANG_PROGRAM([[
-#include <sys/types.h>
-#include <dirent.h>
-]], [[
-DIR *dirp;
-dirp = opendir(".");
-dirfd(dirp);
-closedir(dirp);
-]])],
-[dbus_have_dirfd=yes],
-[dbus_have_dirfd=no])
-AC_MSG_RESULT($dbus_have_dirfd)
-if test "$dbus_have_dirfd" = yes; then
- AC_DEFINE(HAVE_DIRFD,1,[Have dirfd function])
-else
- AC_MSG_CHECKING(for DIR *dirp->dd_fd)
- AC_LINK_IFELSE([AC_LANG_PROGRAM([[
-#include <sys/types.h>
-#include <dirent.h>
- ]], [[
-DIR *dirp;
-int fd;
-dirp = opendir(".");
-fd = dirp->dd_fd;
-closedir(dirp);
- ]])],
- [dbus_have_ddfd=yes],
- [dbus_have_ddfd=no])
- AC_MSG_RESULT($dbus_have_ddfd)
- if test "$dbus_have_ddfd" = yes; then
- AC_DEFINE(HAVE_DDFD,1,[Have the ddfd member of DIR])
- fi
-fi
-
AC_CHECK_HEADERS([execinfo.h],
[AC_SEARCH_LIBS([backtrace], [execinfo],
[AC_DEFINE([HAVE_BACKTRACE], [1],