summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLaurent Bigonville <bigon@bigon.be>2016-10-03 20:08:20 +0200
committerSimon McVittie <smcv@collabora.com>2017-05-31 13:39:29 +0100
commit89419e0a8c385bf2796c5839ea7d2c444f34229a (patch)
tree7d038ff9c80634f88d5dea2787a17fc74efe66ca /configure.ac
parentb119366d0b107f6b8d56364ff5203ee3442f3831 (diff)
downloaddbus-89419e0a8c385bf2796c5839ea7d2c444f34229a.tar.gz
Remove calls to sidget/sidput
sidget and sidput functions are noop and deprecated since libselinux 2.0.86. Also use pkg-config to detect libselinux and force version >= 2.0.86 Bug: https://bugs.freedesktop.org/show_bug.cgi?id=100912 Reviewed-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 64c60ff2..3a518d0f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1011,8 +1011,8 @@ if test x$enable_selinux = xno ; then
have_selinux=no;
else
# See if we have SELinux library
- AC_CHECK_LIB(selinux, is_selinux_enabled,
- have_selinux=yes, have_selinux=no)
+ PKG_CHECK_MODULES([SELINUX], [libselinux >= 2.0.86],
+ [have_selinux=yes], [have_selinux=no])
# see if we have the SELinux header with the new D-Bus stuff in it
if test x$have_selinux = xyes ; then
@@ -1046,7 +1046,7 @@ if test x$have_selinux = xyes ; then
AC_CHECK_FUNC(pthread_create,,[AC_CHECK_LIB(pthread,pthread_create,
[SELINUX_THREAD_LIBS="-lpthread"])])
- SELINUX_LIBS="-lselinux $SELINUX_THREAD_LIBS"
+ SELINUX_LIBS="$SELINUX_LIBS $SELINUX_THREAD_LIBS"
AC_DEFINE(HAVE_SELINUX,1,[SELinux support])
else
SELINUX_LIBS=