summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2017-06-02 14:51:54 +0100
committerSimon McVittie <smcv@collabora.com>2017-12-11 15:50:02 +0000
commit88b3c319281d988d70253b17d59f7ba687042006 (patch)
tree36da83dda6d7e532f94b248cef28341400349f5d /configure.ac
parent39262d0a2913fc8ee951beb3d0241720abf651c0 (diff)
downloaddbus-88b3c319281d988d70253b17d59f7ba687042006.tar.gz
driver: Add a stub implementation of the Containers1 interface
For now, this is considered to be a privileged operation, because the resource-limiting isn't wired up yet. It only contains the bare minimum of API. Signed-off-by: Simon McVittie <smcv@collabora.com> Reviewed-by: Philip Withnall <withnall@endlessm.com> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=101354
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ce1f2c56..2ab704b3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1762,6 +1762,16 @@ AC_ARG_ENABLE([user-session],
AM_CONDITIONAL([DBUS_ENABLE_USER_SESSION],
[test "x$enable_user_session" = xyes])
+AC_ARG_ENABLE([containers],
+ [AS_HELP_STRING([--enable-containers],
+ [enable restricted servers for app containers])],
+ [], [enable_containers=no])
+AS_IF([test "x$enable_containers" = xyes && test "x$dbus_unix" != xyes],
+ [AC_MSG_ERROR([Restricted servers for app containers require Unix])])
+AS_IF([test "x$enable_containers" = xyes],
+ [AC_DEFINE([DBUS_ENABLE_CONTAINERS], [1],
+ [Define to enable restricted servers for app containers])])
+
AC_CONFIG_FILES([
Doxyfile
dbus/Version
@@ -1842,6 +1852,7 @@ echo "
Building assertions: ${enable_asserts}
Building checks: ${enable_checks}
Building bus stats API: ${enable_stats}
+ Building container API: ${enable_containers}
Building SELinux support: ${have_selinux}
Building AppArmor support: ${have_apparmor}
Building inotify support: ${have_inotify}