summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlex Richardson <arichardson@FreeBSD.org>2022-08-14 16:28:56 +0000
committerSimon McVittie <smcv@collabora.com>2022-09-21 11:35:05 +0000
commit6933a9263e30e2dbfb36a038660b9387ee632d32 (patch)
tree645ee67bafdb5f4283d63157b820c0c2461c83bf /configure.ac
parent91f4ac9cf62f8bb99c28ddfa4f376e45fd1b2b94 (diff)
downloaddbus-6933a9263e30e2dbfb36a038660b9387ee632d32.tar.gz
dbus-message.c: skip 1.10 layout compatibility test on new architectures
These static assertions fail on CHERI-enabled architectures such as Arm Morello, where pointers are 128 bits. Architectures with 128-bit pointers were not supported in DBus 1.10, so we can skip the checks for DBus 1.10 structure layout compatibility for architectures with pointer size > 64 bit.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 033a1f8e..aee08dc7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -429,13 +429,17 @@ winsock2.h
ws2tcpip.h
])
+#### Pointer size
+AC_CHECK_SIZEOF(void *)
+DBUS_SIZEOF_VOID_P=$ac_cv_sizeof_void_p
+AC_SUBST(DBUS_SIZEOF_VOID_P)
+
#### Integer sizes
AC_CHECK_SIZEOF(char)
AC_CHECK_SIZEOF(short)
AC_CHECK_SIZEOF(long)
AC_CHECK_SIZEOF(int)
-AC_CHECK_SIZEOF(void *)
AC_CHECK_SIZEOF(long long)
AC_CHECK_SIZEOF(__int64)
@@ -1706,6 +1710,7 @@ echo "
64-bit int: ${DBUS_INT64_TYPE}
32-bit int: ${DBUS_INT32_TYPE}
16-bit int: ${DBUS_INT16_TYPE}
+ pointer size: ${DBUS_SIZEOF_VOID_P}
Doxygen: ${DOXYGEN:-not found}
xmlto: ${XMLTO:-not found}
ducktype: ${DUCKTYPE:-not found}