summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuca Boccassi <bluca@debian.org>2023-03-20 01:40:20 +0000
committerSimon McVittie <smcv@collabora.com>2023-05-15 19:06:54 +0000
commit4364b9ebb3acef566a2c1955423426584147226e (patch)
treeafbef4a885ef77ca7c0adcaf0e8b87912fc8f10e /configure.ac
parent1a74c43c0e545f41b6266713362c42748ee579e8 (diff)
downloaddbus-4364b9ebb3acef566a2c1955423426584147226e.tar.gz
Support /proc in _dbus_file_get_content
procfs has special semantics: most files are 0 size, only one read can be done on a file, and they are not larger than 4MB. Enhance _dbus_file_get_content() so that we can read files from /proc with it. Signed-off-by: Luca Boccassi <bluca@debian.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 92124838..2620f372 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1023,6 +1023,9 @@ if test x$with_valgrind != xno; then
AC_DEFINE([WITH_VALGRIND], [1], [Define to add Valgrind instrumentation])
fi
+AC_CHECK_HEADERS(sys/vfs.h, [AC_CHECK_FUNCS(fstatfs)])
+AC_CHECK_HEADERS([linux/magic.h])
+
#### Set up final flags
LIBDBUS_LIBS="$THREAD_LIBS $NETWORK_libs $SYSTEMD_LIBS"
AC_SUBST([LIBDBUS_LIBS])