summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2022-05-18 15:23:01 +0100
committerSimon McVittie <smcv@collabora.com>2022-10-11 17:14:11 +0100
commit3ca855f2642239ea83c424d8bae5c2a514e55e3b (patch)
treedf5f58d69b37824e2fe5fc096f89138ad84a981a /configure.ac
parent5b9d64023bf61f4383b30f1851f231a65c95bf3f (diff)
downloaddbus-3ca855f2642239ea83c424d8bae5c2a514e55e3b.tar.gz
build: Use AS_IF for system bus socket
Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index ecff6a04..c15ee151 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1330,14 +1330,15 @@ AS_HELP_STRING([--with-systemduserunitdir=DIR], [Directory for systemd user serv
AC_SUBST([systemduserunitdir], [$with_systemduserunitdir])
##### Set up location for system bus socket
-if ! test -z "$with_system_socket"; then
- DBUS_SYSTEM_SOCKET=$with_system_socket
-else
+
+AS_IF([! test -z "$with_system_socket"],
+ [DBUS_SYSTEM_SOCKET=$with_system_socket],
+ [
# We don't use runstatedir for this (yet?), because /var/run has been the
# interoperable system bus socket for 10+ years.
# See https://bugs.freedesktop.org/show_bug.cgi?id=101628
DBUS_SYSTEM_SOCKET=${EXPANDED_LOCALSTATEDIR}/run/dbus/system_bus_socket
-fi
+ ])
AC_SUBST(DBUS_SYSTEM_SOCKET)
AC_DEFINE_UNQUOTED(DBUS_SYSTEM_SOCKET,"$DBUS_SYSTEM_SOCKET",[The name of the socket the system bus listens on by default])