summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2017-12-12 17:41:19 +0000
committerSimon McVittie <smcv@collabora.com>2017-12-12 17:41:19 +0000
commit065e2249ac6840d34e41cd156d3fa2201ca10b6c (patch)
treeb19779203fe98130dc266453996909d651b9df73 /configure.ac
parentc58238f53fc2547063d842ed1cae91137af22458 (diff)
parent224d2c5ec909de449eb7c46ae30c28e6dd03717c (diff)
downloaddbus-065e2249ac6840d34e41cd156d3fa2201ca10b6c.tar.gz
Merge branch 'containers-minimum-101354'
Add experimental support for creating extra servers at runtime, to be used by app containers like Flatpak or Snap. This API is still subject to change and is not compiled in by default. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=101354
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ce1f2c56..2ab704b3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1762,6 +1762,16 @@ AC_ARG_ENABLE([user-session],
AM_CONDITIONAL([DBUS_ENABLE_USER_SESSION],
[test "x$enable_user_session" = xyes])
+AC_ARG_ENABLE([containers],
+ [AS_HELP_STRING([--enable-containers],
+ [enable restricted servers for app containers])],
+ [], [enable_containers=no])
+AS_IF([test "x$enable_containers" = xyes && test "x$dbus_unix" != xyes],
+ [AC_MSG_ERROR([Restricted servers for app containers require Unix])])
+AS_IF([test "x$enable_containers" = xyes],
+ [AC_DEFINE([DBUS_ENABLE_CONTAINERS], [1],
+ [Define to enable restricted servers for app containers])])
+
AC_CONFIG_FILES([
Doxyfile
dbus/Version
@@ -1842,6 +1852,7 @@ echo "
Building assertions: ${enable_asserts}
Building checks: ${enable_checks}
Building bus stats API: ${enable_stats}
+ Building container API: ${enable_containers}
Building SELinux support: ${have_selinux}
Building AppArmor support: ${have_apparmor}
Building inotify support: ${have_inotify}