summaryrefslogtreecommitdiff
path: root/cmake/test/name-test/CMakeLists.txt
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2010-03-20 22:30:16 +0100
committerRalf Habacker <ralf.habacker@freenet.de>2010-03-20 22:33:58 +0100
commitd999abdaa83a89a642ba507d58c36b161e220f3a (patch)
treeae01257bb7158341a8379efeb190d93e3169f641 /cmake/test/name-test/CMakeLists.txt
parent235e8dfe2e1b741bbe117825f6d3fc26fc94ca6f (diff)
downloaddbus-d999abdaa83a89a642ba507d58c36b161e220f3a.tar.gz
CMake dbus libraries usage cleanup.
Renamed DBUS_LIBRARIES to DBUS_INTERNAL_LIBRARIES and moved to top level CMakeLists.txt. Removed obsolate references of dbus-internal library. Added DBUS_LIBRARIES definition which contains only the dbus library.
Diffstat (limited to 'cmake/test/name-test/CMakeLists.txt')
-rw-r--r--cmake/test/name-test/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/cmake/test/name-test/CMakeLists.txt b/cmake/test/name-test/CMakeLists.txt
index df6d178b..d26e642d 100644
--- a/cmake/test/name-test/CMakeLists.txt
+++ b/cmake/test/name-test/CMakeLists.txt
@@ -6,15 +6,15 @@ add_definitions(-DDBUS_COMPILATION)
# there is also a test-names executable, don't know if this is the same
add_executable(test-names2 ${NAMEtest-DIR}/test-names.c)
-target_link_libraries(test-names2 ${DBUS_LIBRARIES})
+target_link_libraries(test-names2 ${DBUS_INTERNAL_LIBRARIES})
ADD_TEST(test-names2 ${EXECUTABLE_OUTPUT_PATH}/test-names2)
add_executable(test-pending-call-dispatch ${NAMEtest-DIR}/test-pending-call-dispatch.c)
-target_link_libraries(test-pending-call-dispatch ${DBUS_LIBRARIES})
+target_link_libraries(test-pending-call-dispatch ${DBUS_INTERNAL_LIBRARIES})
ADD_TEST(test-pending-call-dispatch ${EXECUTABLE_OUTPUT_PATH}/test-pending-call-dispatch)
add_executable(test-thread-init ${NAMEtest-DIR}/test-threads-init.c)
-target_link_libraries(test-thread-init ${DBUS_LIBRARIES})
+target_link_libraries(test-thread-init ${DBUS_INTERNAL_LIBRARIES})
ADD_TEST(test-thread-init ${EXECUTABLE_OUTPUT_PATH}/test-thread-init)
endif (DBUS_BUILD_TESTS)