summaryrefslogtreecommitdiff
path: root/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri John Ledkov <dimitri.j.ledkov@intel.com>2015-03-02 11:55:54 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2015-05-27 11:49:41 +0100
commit70950325c7986737ccf54bb71dbdd89958da181d (patch)
tree19c94a0798b45c3b14f1b7a55069b3b6d1e794c8 /cmake/CMakeLists.txt
parentb2c61ca6ea2dd9ba62ebddc98fa295ee84ab3949 (diff)
downloaddbus-70950325c7986737ccf54bb71dbdd89958da181d.tar.gz
Adjust cmake build to match autoconf installation locations.
Bug: https://bugs.freedesktop.org/show_bug.cgi?id=89280 Reviewed-by: Simon McVittie <simon.mcvittie@collabora.co.uk>
Diffstat (limited to 'cmake/CMakeLists.txt')
-rw-r--r--cmake/CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/cmake/CMakeLists.txt b/cmake/CMakeLists.txt
index 20a8334f..e072dfa0 100644
--- a/cmake/CMakeLists.txt
+++ b/cmake/CMakeLists.txt
@@ -86,11 +86,15 @@ set(EXPANDED_LIBDIR ${DBUS_INSTALL_DIR}/lib)
set(EXPANDED_INCLUDEDIR ${DBUS_INSTALL_DIR}/include)
set(EXPANDED_BINDIR ${DBUS_INSTALL_DIR}/bin)
set(EXPANDED_SYSCONFDIR ${DBUS_INSTALL_DIR}/etc)
+set(EXPANDED_LOCALSTATEDIR ${DBUS_INSTALL_DIR}/var)
set(EXPANDED_DATADIR ${DBUS_INSTALL_DIR}/${DBUS_DATADIR})
set(DBUS_MACHINE_UUID_FILE ${DBUS_INSTALL_DIR}/lib/dbus/machine-id)
set(DBUS_BINDIR ${EXPANDED_BINDIR})
set(DBUS_DAEMONDIR ${EXPANDED_BINDIR})
-set(DBUS_LOCALSTATEDIR ${DBUS_INSTALL_DIR}/var)
+set(DBUS_LOCALSTATEDIR ${EXPANDED_LOCALSTATEDIR})
+set(DBUS_SYSCONFDIR ${EXPANDED_SYSCONFDIR})
+set(DBUS_LIBEXECDIR ${EXPANDED_LIBDIR})
+set(DBUS_DATADIR ${EXPANDED_DATADIR})
#enable building of shared library
SET(BUILD_SHARED_LIBS ON)
@@ -447,8 +451,8 @@ if (WIN32)
set (DBUS_SESSION_BUS_LISTEN_ADDRESS "autolaunch:" CACHE STRING "session bus default listening address")
set (DBUS_SESSION_BUS_CONNECT_ADDRESS "autolaunch:" CACHE STRING "session bus fallback address for clients")
- set (DBUS_SYSTEM_CONFIG_FILE "etc/dbus-1/system.conf")
- set (DBUS_SESSION_CONFIG_FILE "etc/dbus-1/session.conf")
+ set (DBUS_SYSTEM_CONFIG_FILE "share/dbus-1/system.conf")
+ set (DBUS_SESSION_CONFIG_FILE "share/dbus-1/session.conf")
# bus-test expects a non empty string
set (DBUS_USER "Administrator")
set (DBUS_TEST_USER "guest")