summaryrefslogtreecommitdiff
path: root/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2017-09-29 12:27:11 +0100
committerSimon McVittie <smcv@collabora.com>2017-09-29 14:04:57 +0100
commit6a6521746bce81c50d77b560b2ee9948c1a5efd0 (patch)
tree5c5c7aa914d134ef3a4294e88947376e63e76806 /cmake/CMakeLists.txt
parent633a208ce72eef3d8322f97c8671ce577aa87775 (diff)
downloaddbus-6a6521746bce81c50d77b560b2ee9948c1a5efd0.tar.gz
unix: Condition Linux-specific abstract sockets on __linux__
This is nicer for cross-compiling, because AC_RUN_IFELSE can't work there. In practice abstract sockets are supported on Linux since 2.2 (so, all relevant versions), and on no other platform; so it seems futile to keep this complexity. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=34905 Signed-off-by: Simon McVittie <smcv@collabora.com> Reviewed-by: Philip Withnall <withnall@endlessm.com>
Diffstat (limited to 'cmake/CMakeLists.txt')
-rw-r--r--cmake/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/cmake/CMakeLists.txt b/cmake/CMakeLists.txt
index a003f282..a9f53780 100644
--- a/cmake/CMakeLists.txt
+++ b/cmake/CMakeLists.txt
@@ -121,7 +121,6 @@ if (WIN32)
endif (WIN32)
if(NOT WIN32)
- option (DBUS_ENABLE_ABSTRACT_SOCKETS "enable support for abstract sockets" ON)
set (CMAKE_THREAD_PREFER_PTHREAD ON)
include (FindThreads)
endif(NOT WIN32)