summaryrefslogtreecommitdiff
path: root/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2015-03-05 09:01:31 +0100
committerRalf Habacker <ralf.habacker@freenet.de>2015-03-05 13:52:57 +0100
commit4d8a27701ba8f278ea61f513218dac1af3b7e589 (patch)
tree9bbe3a6932f48100b55cc6133b0880de357d84ef /cmake/CMakeLists.txt
parent8696bfdf07a65f1887a907db869f8986fd21a40a (diff)
downloaddbus-4d8a27701ba8f278ea61f513218dac1af3b7e589.tar.gz
Add cmake macro autoheaderchecks().
This macro prints out any include file defined as HAVE_..._H in the config header template and not in the related cmake configure checks file. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=85418 Reviewed-by: Simon McVittie <simon.mcvittie@collabora.co.uk>
Diffstat (limited to 'cmake/CMakeLists.txt')
-rw-r--r--cmake/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/cmake/CMakeLists.txt b/cmake/CMakeLists.txt
index 607d9b1a..8c006d00 100644
--- a/cmake/CMakeLists.txt
+++ b/cmake/CMakeLists.txt
@@ -17,6 +17,7 @@ endif(COMMAND cmake_policy)
include(MacrosAutotools)
autoinit(../configure.ac)
autoversion(dbus)
+autoheaderchecks(../config.h.in ConfigureChecks.cmake)
# used by file version info
set (DBUS_PATCH_VERSION "0")