summaryrefslogtreecommitdiff
path: root/bus/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2015-02-20 16:14:08 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2015-02-20 20:50:04 +0000
commitc35d7d1eb773c27018ec4e326bfac0b973e743c0 (patch)
treefde2d3fab110cd15d399808a8bc1272f947a1b47 /bus/Makefile.am
parent57696a2e8a5eb2df3177f5b52c512a14f3cab1f5 (diff)
downloaddbus-c35d7d1eb773c27018ec4e326bfac0b973e743c0.tar.gz
Fix static linking with mingw
Now that we're normally linking libdbus-1 dynamically, we need to use DBUS_STATIC_BUILD_CPPFLAGS in every Makefile that would normally link it dynamically, but might link it statically if we are only building static libraries. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=83115 Reviewed-by: Ralf Habacker <ralf.habacker@freenet.de>
Diffstat (limited to 'bus/Makefile.am')
-rw-r--r--bus/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/bus/Makefile.am b/bus/Makefile.am
index 0b9998da..1db7c9e1 100644
--- a/bus/Makefile.am
+++ b/bus/Makefile.am
@@ -18,11 +18,11 @@ DBUS_LAUNCHER_LIBS = \
AM_CPPFLAGS = \
-I$(top_srcdir) \
+ $(DBUS_STATIC_BUILD_CPPFLAGS) \
$(XML_CFLAGS) \
$(APPARMOR_CFLAGS) \
-DDBUS_SYSTEM_CONFIG_FILE=\""$(configdir)/system.conf"\" \
-DDBUS_COMPILATION \
- -DDBUS_STATIC_BUILD \
$(NULL)
# if assertions are enabled, improve backtraces