summaryrefslogtreecommitdiff
path: root/bus/Makefile.am
diff options
context:
space:
mode:
authorKay Sievers <kay.sievers@vrfy.org>2010-09-03 15:12:19 +0200
committerLennart Poettering <lennart@poettering.net>2010-09-06 03:21:17 +0200
commit8a440f7441ac47e0828ce978c7f105dca845f1cf (patch)
tree0bb70e727f8dec7b142ce4d1e9aec1c3280cf71d /bus/Makefile.am
parent929d9567d96992c01ebf8bbc0d40d9dc14677ca5 (diff)
downloaddbus-8a440f7441ac47e0828ce978c7f105dca845f1cf.tar.gz
systemd: enable the dbus service unconditionally
Since D-Bus is a core part of the OS don't make this service optional.
Diffstat (limited to 'bus/Makefile.am')
-rw-r--r--bus/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/bus/Makefile.am b/bus/Makefile.am
index a5889ff1..5c4fb15b 100644
--- a/bus/Makefile.am
+++ b/bus/Makefile.am
@@ -223,6 +223,11 @@ if HAVE_SYSTEMD
# Install dbus.socket as default implementation of a D-Bus stack
$(mkinstalldirs) $(DESTDIR)$(systemdsystemunitdir)/dbus.target.wants
$(LN_S) ../dbus.socket $(DESTDIR)$(systemdsystemunitdir)/dbus.target.wants/dbus.socket
+# Unconditionally enable D-Bus on systemd installations
+ $(mkinstalldirs) $(DESTDIR)$(systemdsystemunitdir)/sockets.target.wants
+ $(LN_S) ../dbus.socket $(DESTDIR)$(systemdsystemunitdir)/sockets.target.wants/dbus.socket
+ $(mkinstalldirs) $(DESTDIR)$(systemdsystemunitdir)/multi-user.target.wants
+ $(LN_S) ../dbus.service $(DESTDIR)$(systemdsystemunitdir)/multi-user.target.wants/dbus.service
endif
#### Init scripts fun