summaryrefslogtreecommitdiff
path: root/bus/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2014-09-11 17:37:49 +0100
committerRalf Habacker <ralf.habacker@freenet.de>2014-09-15 13:33:21 +0200
commit87448fed6f37ab0f036d88ac0d4af2e1bfc59a69 (patch)
tree103689c05d575abfe66f9de0bcf2e066961fa323 /bus/Makefile.am
parent3765075c5f7c115abd10b0b76df81ae230ffceae (diff)
downloaddbus-87448fed6f37ab0f036d88ac0d4af2e1bfc59a69.tar.gz
Make various system-bus-related things Unix-only
There is no system bus on Windows, and there won't be until/unless it can be secure. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=83583 Reviewed-by: Ralf Habacker <ralf.habacker@freenet.de>
Diffstat (limited to 'bus/Makefile.am')
-rw-r--r--bus/Makefile.am18
1 files changed, 11 insertions, 7 deletions
diff --git a/bus/Makefile.am b/bus/Makefile.am
index f335e30c..25029b4f 100644
--- a/bus/Makefile.am
+++ b/bus/Makefile.am
@@ -33,9 +33,11 @@ CONFIG_IN_FILES= \
system.conf.in \
org.freedesktop.dbus-session.plist.in
-config_DATA= \
- session.conf \
- system.conf
+config_DATA = session.conf
+
+if DBUS_UNIX
+config_DATA += system.conf
+endif
if DBUS_ENABLE_LAUNCHD
agentdir=$(LAUNCHD_AGENT_DIR)
@@ -169,11 +171,11 @@ if DBUS_ENABLE_EMBEDDED_TESTS
## even when not doing "make check"
# run as a test by test/Makefile.am
-noinst_PROGRAMS += test-bus test-bus-system
+noinst_PROGRAMS += test-bus
if DBUS_UNIX
# run as a test by test/Makefile.am
-noinst_PROGRAMS += test-bus-launch-helper
+noinst_PROGRAMS += test-bus-launch-helper test-bus-system
# this is used by the tests but is not,itself, a test
noinst_PROGRAMS += dbus-daemon-launch-helper-test
endif DBUS_UNIX
@@ -203,11 +205,13 @@ clean-local:
/bin/rm *.bb *.bbg *.da *.gcov || true
install-data-hook:
- $(mkinstalldirs) $(DESTDIR)$(localstatedir)/run/dbus
- $(mkinstalldirs) $(DESTDIR)$(configdir)/system.d
$(mkinstalldirs) $(DESTDIR)$(configdir)/session.d
$(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/services
+if DBUS_UNIX
+ $(mkinstalldirs) $(DESTDIR)$(localstatedir)/run/dbus
+ $(mkinstalldirs) $(DESTDIR)$(configdir)/system.d
$(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/system-services
+endif
if HAVE_SYSTEMD
# Install dbus.socket as default implementation of a D-Bus stack.
# Deliberately not using $(LN_S) here: ln -fs is not universally portable,