summaryrefslogtreecommitdiff
path: root/bus/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2011-02-21 16:23:24 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2011-04-26 18:47:23 +0100
commit53db0b73c4d103ab0081993474c0fac7cc05ffc0 (patch)
tree4e825ca110a13ab43e4c3949e1605d0cba26121c /bus/Makefile.am
parentb0acdedae19f54c08e0f61833db8faf14aacaf87 (diff)
downloaddbus-53db0b73c4d103ab0081993474c0fac7cc05ffc0.tar.gz
Don't force use of -fPIE for the dbus-daemon if apparently supported
It's a minor security benefit, but not automatically beneficial (it enables ASLR, but breaks prelinking, some buggy toolchains, and some gdb versions). Distributions who know their infrastructure works well can enable it just as easily via ./configure CFLAGS="-fPIE" LDFLAGS="-pie" without extra support from us, and that's a generic solution applicable to many packages. Similarly, don't force libdbus and libdbus-internal to be PIC: libtool knows better than we do whether that's necessary/beneficial on a particular platform. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=16621 Bug: https://bugs.freedesktop.org/show_bug.cgi?id=27215 Bug-NB: NB#171940 Reviewed-by: Colin Walters <walters@verbum.org>
Diffstat (limited to 'bus/Makefile.am')
-rw-r--r--bus/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/bus/Makefile.am b/bus/Makefile.am
index 5cba22ba..dfb3bc34 100644
--- a/bus/Makefile.am
+++ b/bus/Makefile.am
@@ -1,8 +1,9 @@
configdir=$(sysconfdir)/dbus-1
dbus_daemon_execdir = $(DBUS_DAEMONDIR)
-INCLUDES=-I$(top_srcdir) $(DBUS_BUS_CFLAGS) @PIE_CFLAGS@ \
- -DDBUS_SYSTEM_CONFIG_FILE=\""$(configdir)/system.conf"\" \
+INCLUDES = -I$(top_srcdir) \
+ $(DBUS_BUS_CFLAGS) \
+ -DDBUS_SYSTEM_CONFIG_FILE=\""$(configdir)/system.conf"\" \
-DDBUS_COMPILATION
EFENCE=
@@ -88,7 +89,7 @@ dbus_daemon_LDADD= \
$(EFENCE) \
$(DBUS_BUS_LIBS)
-dbus_daemon_LDFLAGS=@R_DYNAMIC_LDFLAG@ @SECTION_LDFLAGS@ @PIE_LDFLAGS@
+dbus_daemon_LDFLAGS=@R_DYNAMIC_LDFLAG@ @SECTION_LDFLAGS@
LAUNCH_HELPER_SOURCES= \
$(XML_SOURCES) \