summaryrefslogtreecommitdiff
path: root/bus/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2011-06-14 17:44:35 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2011-07-29 11:07:19 +0100
commit16aae2855dacdfacf453598c54ebfe47e790b27e (patch)
tree9fefd5feb33f1c5d4862c018a33bef4eb99caa0f /bus/Makefile.am
parent2ec1b6cca5a52be5829e7c14e0ade052275a9db2 (diff)
downloaddbus-16aae2855dacdfacf453598c54ebfe47e790b27e.tar.gz
Move knowledge of what the bus daemon/launcher need to link into bus/
Diffstat (limited to 'bus/Makefile.am')
-rw-r--r--bus/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/bus/Makefile.am b/bus/Makefile.am
index 9ec12890..c83c80ac 100644
--- a/bus/Makefile.am
+++ b/bus/Makefile.am
@@ -1,8 +1,22 @@
configdir=$(sysconfdir)/dbus-1
dbus_daemon_execdir = $(DBUS_DAEMONDIR)
+DBUS_BUS_LIBS = \
+ $(XML_LIBS) \
+ $(SELINUX_LIBS) \
+ $(THREAD_LIBS) \
+ $(ADT_LIBS) \
+ $(NETWORK_libs) \
+ $(NULL)
+
+DBUS_LAUNCHER_LIBS = \
+ $(XML_LIBS) \
+ $(THREAD_LIBS) \
+ $(NETWORK_libs) \
+ $(NULL)
+
INCLUDES = -I$(top_srcdir) \
- $(DBUS_BUS_CFLAGS) \
+ $(XML_CFLAGS) \
-DDBUS_SYSTEM_CONFIG_FILE=\""$(configdir)/system.conf"\" \
-DDBUS_COMPILATION