summaryrefslogtreecommitdiff
path: root/bus/Makefile.am
diff options
context:
space:
mode:
authorTyler Hicks <tyhicks@canonical.com>2014-02-10 19:02:04 -0600
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2015-02-18 17:04:00 +0000
commit06033cb20fb6b33fc26c2ef3f5bec1bf75596e34 (patch)
tree548ba7b8c62f81ab3663e6753fa1fcd073a15dba /bus/Makefile.am
parentf62bff5bca2c187262a550f6f0a0c2a662adaaf6 (diff)
downloaddbus-06033cb20fb6b33fc26c2ef3f5bec1bf75596e34.tar.gz
Add apparmor element support to bus config parsing
The <apparmor> element can contain a single mode attribute that has one of three values: "enabled" "disabled" "required" "enabled" means that kernel support is autodetected and, if available, AppArmor mediation occurs in dbus-daemon. If kernel support is not detected, mediation is disabled. "disabled" means that mediation does not occur. "required" means that kernel support must be detected for dbus-daemon to start. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=75113 Signed-off-by: Tyler Hicks <tyhicks@canonical.com> Reviewed-by: Simon McVittie <simon.mcvittie@collabora.co.uk>
Diffstat (limited to 'bus/Makefile.am')
-rw-r--r--bus/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/bus/Makefile.am b/bus/Makefile.am
index e0eead3c..9d3cb006 100644
--- a/bus/Makefile.am
+++ b/bus/Makefile.am
@@ -4,6 +4,7 @@ dbus_daemon_execdir = $(DBUS_DAEMONDIR)
DBUS_BUS_LIBS = \
$(XML_LIBS) \
$(SELINUX_LIBS) \
+ $(APPARMOR_LIBS) \
$(THREAD_LIBS) \
$(ADT_LIBS) \
$(NETWORK_libs) \
@@ -70,6 +71,8 @@ BUS_SOURCES= \
activation.c \
activation.h \
activation-exit-codes.h \
+ apparmor.c \
+ apparmor.h \
bus.c \
bus.h \
config-parser.c \