summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2011-02-02 16:51:30 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2011-02-17 17:07:12 +0000
commit9a97f820793a4400d7d2dbb71838f5be06e427c6 (patch)
tree429d1b36c781fd87d2dc8dedb05a02394268f657 /Makefile.am
parentf6e2c958a0345a57c6b9b7f27acf5aee2ff1877b (diff)
downloaddbus-9a97f820793a4400d7d2dbb71838f5be06e427c6.tar.gz
Import compiler.m4 and lcov.am from telepathy-glib, and use them to replace gcov
Reviewed-by: Colin Walters <walters@verbum.org> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=10887
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am42
1 files changed, 2 insertions, 40 deletions
diff --git a/Makefile.am b/Makefile.am
index 2ce25d5c..ac7dcb15 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,46 +23,6 @@ EXTRA_DIST = \
all-local: Doxyfile
-if DBUS_GCOV_ENABLED
-clean-gcov:
- find -name "*.da" -o -name "*.gcov" | xargs rm || true
-
-clean-bbg:
- find -name "*.bbg" -o -name "*.bb" | xargs rm || true
-
-GCOV_DIRS=dbus bus
-
-## .PHONY so it always rebuilds it
-.PHONY: coverage-report.txt
-coverage-report.txt:
- BBG_FILES=`find $(GCOV_DIRS) -name "*.bbg" -o -name "*.gcno"` ; \
- C_FILES= ; \
- for F in $$BBG_FILES ; do \
- F_nolibs=`echo $$F | sed -e 's/.libs\///g'` ; \
- C=`echo $$F_nolibs | sed -e 's/.bbg/.c/g' | sed -e 's/.gcno/.c/g'` ; \
- B=`basename $$F .bbg` ; \
- D=`dirname $$F` ; \
- DA=`echo $$F | sed -e 's/.bbg/.da/g'` ; \
- DA_libs=`echo $$D/.libs/$$B/.da` ; \
- if test -e $$DA || test -e $$DA_libs; then \
- C_FILES="$$C_FILES $$C" ; \
- fi ; \
- done ; \
- echo $$C_FILES ; \
- $(top_builddir)/test/decode-gcov --report $$C_FILES > coverage-report.txt
-
-check-coverage: clean-gcov all check coverage-report.txt
- cat coverage-report.txt
-
-else
-coverage-report.txt:
- echo "Need to reconfigure with --enable-gcov"
-
-check-coverage:
- echo "Need to reconfigure with --enable-gcov"
-
-endif
-
update-authors:
git shortlog -s -e | cut -c 8- | sort > AUTHORS
@@ -70,3 +30,5 @@ DISTCHECK_CONFIGURE_FLAGS = \
--with-systemdsystemunitdir=$$dc_install_base/$(systemdsystemunitdir)
ACLOCAL_AMFLAGS = -I m4
+
+include tools/lcov.am