summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a9fd3d103..f38e1c0ce 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1657,7 +1657,7 @@ if test -z "$ssl_backends" -o "x$OPT_SSL" != xno &&
dnl still no, but what about with -ldl?
AC_MSG_CHECKING([OpenSSL linking with -ldl])
- LIBS="$LIBS -ldl"
+ LIBS="$LIBS -ldl -lcrypto"
AC_TRY_LINK(
[
#include <openssl/err.h>
@@ -1674,7 +1674,7 @@ if test -z "$ssl_backends" -o "x$OPT_SSL" != xno &&
dnl ok, so what about bouth -ldl and -lpthread?
AC_MSG_CHECKING([OpenSSL linking with -ldl and -lpthread])
- LIBS="$LIBS -lpthread"
+ LIBS="$CLEANLIBS -ldl -lpthread -lcrypto"
AC_TRY_LINK(
[
#include <openssl/err.h>