summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2022-02-07 17:17:31 +0100
committerDaniel Stenberg <daniel@haxx.se>2022-02-07 23:27:57 +0100
commitff4bf6bfb5572c7f58dd6151afc8d60210118390 (patch)
tree4119e5f14290a7c271edf927af88e3c13fb0499f /lib/Makefile.am
parent436398bef5d161967f7ecf9576be065aff36b2fe (diff)
downloadcurl-ff4bf6bfb5572c7f58dd6151afc8d60210118390.tar.gz
configure: remove support for "embedded ares"
In March 2010 (commit 4259d2df7dd) we removed the embedded 'ares' directory from the curl source tree but we have since supported especially detecting and using that build directory. The time has come to remove that kludge and ask users to specify the c-ares dir correctly with --enable-ares. Closes #8397
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am7
1 files changed, 0 insertions, 7 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 85af90d0d..a81443eb7 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -48,18 +48,11 @@ CFLAGS += @CURL_CFLAG_EXTRAS@
# $(top_srcdir)/include is for libcurl's external include files
# $(top_builddir)/lib is for libcurl's generated lib/curl_config.h file
# $(top_srcdir)/lib for libcurl's lib/curl_setup.h and other "private" files
-# $(top_builddir)/ares is for in-tree c-ares's generated ares_build.h file
-# $(top_srcdir)/ares is for in-tree c-ares's external include files
AM_CPPFLAGS = -I$(top_srcdir)/include \
-I$(top_builddir)/lib \
-I$(top_srcdir)/lib
-if USE_EMBEDDED_ARES
-AM_CPPFLAGS += -I$(top_builddir)/ares \
- -I$(top_srcdir)/ares
-endif
-
# Prevent LIBS from being used for all link targets
LIBS = $(BLANK_AT_MAKETIME)