summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorBen Greear <greearb@candelatech.com>2010-07-19 18:07:09 +0200
committerDaniel Stenberg <daniel@haxx.se>2010-07-21 21:29:47 +0200
commitd6981cb508c050accdc879e6b4886193751ae72f (patch)
tree9caa1ee30cb246434ef4467725e6151447ab80a8 /lib/Makefile.am
parent40ecd6c9b8104019bc210d6cb39dfbf79389550c (diff)
downloadcurl-d6981cb508c050accdc879e6b4886193751ae72f.tar.gz
build: Enable configure --enable-werror
This passes -Werror to gcc when building curl and libcurl, allowing easy dection of compile warnings. Signed-off-by: Ben Greear <greearb@candelatech.com>
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 53d65dedd..89bc1fd3e 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -44,6 +44,9 @@ CLEANFILES = $(DSP) $(VCPROJ)
lib_LTLIBRARIES = libcurl.la
LIBCURL_LIBS = @LIBCURL_LIBS@
+# This might hold -Werror
+CFLAGS += @CURL_CFLAG_EXTRAS@
+
# Specify our include paths here, and do it relative to $(top_srcdir) and
# $(top_builddir), to ensure that these paths which belong to the library
# being currently built and tested are searched before the library which