summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2018-10-23 00:33:27 +0200
committerDaniel Stenberg <daniel@haxx.se>2018-10-27 15:59:38 +0200
commitbe208141915f18d4ffae66078303fe15d717c8b5 (patch)
treed27562b8d9c0550dff39094cb1577ac72ffad3f8 /lib/Makefile.am
parent803496fa10822cb3fa15e51d3a189e8a948d33a4 (diff)
downloadcurl-be208141915f18d4ffae66078303fe15d717c8b5.tar.gz
Makefile: add 'tidy' target that runs clang-tidy
Available in the root, src and lib dirs. Closes #3163
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 4f3c16db4..a7b5262b9 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -144,3 +144,11 @@ if CURLDEBUG
# for debug builds, we scan the sources on all regular make invokes
all-local: checksrc
endif
+
+# disable the tests that are mostly causing false positives
+TIDYFLAGS=-checks=-clang-analyzer-security.insecureAPI.strcpy,-clang-analyzer-optin.performance.Padding,-clang-analyzer-valist.Uninitialized,-clang-analyzer-core.NonNullParamChecker,-clang-analyzer-core.NullDereference -quiet
+
+TIDY:=clang-tidy
+
+tidy:
+ $(TIDY) $(CSOURCES) $(TIDYFLAGS) -- $(AM_CPPFLAGS) $(CPPFLAGS) -DHAVE_CONFIG_H