summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorViktor Szakats <commit@vsz.me>2022-10-27 06:45:32 +0000
committerViktor Szakats <commit@vsz.me>2022-10-27 06:45:32 +0000
commitb7260c4fda95196b2fa16f32b5913f25323e5098 (patch)
treed494ad5ef4d49a9d150cee92241aeb9a0e31eb6a /lib/Makefile.am
parent811c799f2db1bbcf22e7ceee1e8c2c21525274de (diff)
downloadcurl-b7260c4fda95196b2fa16f32b5913f25323e5098.tar.gz
windows: fix linking .rc to shared curl with autotools
`./configure --enable-shared --disable-static` fails when trying to link a shared `curl.exe`, due to `libtool` magically changing the output filename of `windres` to one that it doesn't find when linking: ``` /bin/sh ../libtool --tag=RC --mode=compile windres -I../../curl/include -DCURL_EMBED_MANIFEST -i ../../curl/src/curl.rc -o curl.o libtool: compile: windres -I../../curl/include -DCURL_EMBED_MANIFEST -i ../../curl/src/curl.rc -o .libs/curl.o [...] CCLD curl.exe clang: error: no such file or directory: 'curl.o' ``` Let's resolve this by skipping `libtool` and calling `windres` directly when building `src` (aka `curl.exe`). Leave `lib` unchanged, as it does need the `libtool` magic. This solution is compatible with building a static `curl.exe`. This build scenario is not CI-tested. While here, delete an obsolete comment about a permanent `libtool` warning that we've resolved earlier. Regression from 6de7322c03d5b4d91576a7d9fc893e03cc9d1057 Reported-by: Christoph Reiter Fixes #9803 Closes #9805
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 5d2df8bff..cd1ca97a5 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -155,7 +155,6 @@ optiontable:
perl optiontable.pl < $(top_srcdir)/include/curl/curl.h > easyoptions.c
if OS_WINDOWS
-# Warning is "normal": libtool: error: ignoring unknown tag RC
.rc.lo:
$(LIBTOOL) --tag=RC --mode=compile $(RC) -I$(top_srcdir)/include $(RCFLAGS) -i $< -o $@
endif