summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2011-06-01 21:39:18 +0200
committerYang Tse <yangsita@gmail.com>2011-06-01 21:40:09 +0200
commitaa76dec33af3d93f046143e7e7c853c49ef54380 (patch)
treeb6403245364c2c24473d98bf81f9a78735da3732 /lib/Makefile.am
parentd6bb8dcc23b5e607e2f30c63d9cf13371219df54 (diff)
downloadcurl-aa76dec33af3d93f046143e7e7c853c49ef54380.tar.gz
unit tests: more build adjustments
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am18
1 files changed, 9 insertions, 9 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index d3dc9af91..f2e54db95 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -106,7 +106,7 @@ endif
# For the full guide on libcurl ABI rules, see docs/libcurl/ABI
if NO_UNDEFINED
-# The -no-undefined flag is CRUCIAL for this to build fine on Cygwin.
+# The -no-undefined flag is crucial to build fine on some platforms
UNDEF = -no-undefined
endif
@@ -116,18 +116,18 @@ if MIMPURE
MIMPURE = -mimpure-text
endif
-LINKFLAGS=$(UNDEF) $(MIMPURE) $(LIBCURL_LIBS)
+libcurl_la_LDFLAGS = $(UNDEF) $(VERSIONINFO) $(MIMPURE) $(LIBCURL_LIBS)
-libcurl_la_LDFLAGS = $(LINKFLAGS) $(VERSIONINFO)
-
-# as unit testing will compile and link everything an extra time, we only
-# do it if debug is enabled
-if CURLDEBUG
+# unit testing static library built only along with unit tests
+if BUILD_UNITTESTS
noinst_LTLIBRARIES = libcurlu.la
-libcurlu_la_CPPFLAGS = $(AM_CPPFLAGS) -DUNITTESTS
-libcurlu_la_LDFLAGS = -static $(LINKFLAGS)
+else
+noinst_LTLIBRARIES =
endif
+libcurlu_la_CPPFLAGS = $(AM_CPPFLAGS) -DUNITTESTS
+libcurlu_la_LDFLAGS = -static $(LIBCURL_LIBS)
+
# Makefile.inc provides the CSOURCES and HHEADERS defines
include Makefile.inc