summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2016-04-03 23:06:44 +0200
committerDaniel Stenberg <daniel@haxx.se>2016-04-03 23:07:30 +0200
commita8b51a179a1b6d4c139b0c3e1b19f029cd65d89a (patch)
treecfcbaf387f431c2b24c50f3cce7693fa809433a9 /lib/Makefile.am
parent1571da69b54ed4cb7c2eafd43ce728d8afebf50f (diff)
downloadcurl-a8b51a179a1b6d4c139b0c3e1b19f029cd65d89a.tar.gz
lib/src: fix the checksrc invoke
... now works correctly when invoke from the root makefile
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 6f5317a64..d74eb14ca 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -5,7 +5,7 @@
# | (__| |_| | _ <| |___
# \___|\___/|_| \_\_____|
#
-# Copyright (C) 1998 - 2015, Daniel Stenberg, <daniel@haxx.se>, et al.
+# Copyright (C) 1998 - 2016, Daniel Stenberg, <daniel@haxx.se>, et al.
#
# This software is licensed as described in the file COPYING, which
# you should have received as part of this distribution. The terms
@@ -146,7 +146,7 @@ libcurl_la_SOURCES = $(CSOURCES) $(HHEADERS)
libcurlu_la_SOURCES = $(CSOURCES) $(HHEADERS)
checksrc:
- @@PERL@ $(top_srcdir)/lib/checksrc.pl -D$(top_srcdir)/lib $(CSOURCES) $(HHEADERS)
+ @PERL@ $(top_srcdir)/lib/checksrc.pl -W$(top_srcdir)/lib/curl_config.h $(top_srcdir)/lib/*.[ch]
if CURLDEBUG
# for debug builds, we scan the sources on all regular make invokes