summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2016-04-18 20:10:52 +0200
committerDaniel Stenberg <daniel@haxx.se>2016-04-18 20:10:52 +0200
commita542536cf6e8f2eab0788486a60f810a58cb3b3e (patch)
tree652abd658006babe74d4d72a3c12ceaebb6db5b5 /lib/Makefile.am
parentfb823d24f1b5c26a5f4728e15d3bbab777f7be33 (diff)
downloadcurl-a542536cf6e8f2eab0788486a60f810a58cb3b3e.tar.gz
checksrc: pass on -D so the whitelists are found correctly
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 1e0fda387..7b3c585ac 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -146,8 +146,8 @@ libcurl_la_SOURCES = $(CSOURCES) $(HHEADERS)
libcurlu_la_SOURCES = $(CSOURCES) $(HHEADERS)
checksrc:
- @PERL@ $(top_srcdir)/lib/checksrc.pl -W$(top_srcdir)/lib/curl_config.h \
- $(top_srcdir)/lib/*.[ch] $(top_srcdir)/lib/vauth/*.[ch] $(top_srcdir)/lib/vtls/*.[ch]
+ @PERL@ $(srcdir)/checksrc.pl -D$(srcdir) -W$(srcdir)/curl_config.h \
+ $(srcdir)/*.[ch] $(srcdir)/vauth/*.[ch] $(srcdir)/vtls/*.[ch]
if CURLDEBUG
# for debug builds, we scan the sources on all regular make invokes