summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2011-06-01 14:43:25 +0200
committerYang Tse <yangsita@gmail.com>2011-06-01 14:43:25 +0200
commit685359d4c3881acdb4f11285bd77d56a867e09c9 (patch)
tree01e6d867033964ed566b5d14a546381588a95ebe /lib/Makefile.am
parenta689072f33ae5a3a59586fb419b2e3d6a74f5482 (diff)
downloadcurl-685359d4c3881acdb4f11285bd77d56a867e09c9.tar.gz
makefile: avoid preprocessor definition usage when linking
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 3d3e91c52..d3dc9af91 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -124,7 +124,7 @@ libcurl_la_LDFLAGS = $(LINKFLAGS) $(VERSIONINFO)
# do it if debug is enabled
if CURLDEBUG
noinst_LTLIBRARIES = libcurlu.la
-libcurlu_la_CFLAGS = -DUNITTESTS
+libcurlu_la_CPPFLAGS = $(AM_CPPFLAGS) -DUNITTESTS
libcurlu_la_LDFLAGS = -static $(LINKFLAGS)
endif