summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2011-04-22 23:00:31 +0200
committerDaniel Stenberg <daniel@haxx.se>2011-04-27 09:09:35 +0200
commit1b758b01c170633e4514483c3605eaad9645973e (patch)
treeeb8c63138cb7ee633866568286c0fbca9881bbfe /lib/Makefile.am
parent7ddcc8fea4d292f453b33ea2561f26c70ef156ce (diff)
downloadcurl-1b758b01c170633e4514483c3605eaad9645973e.tar.gz
lib/make: run checksrc.pl once for all files
Since it now supports multiple files this will be faster and will show problems for more file than one at a time - more convenient.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 15dbcd290..0e80f5e18 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -188,6 +188,6 @@ $(VCPROJ): vc8proj.head vc8proj.foot Makefile.am
if CURLDEBUG
# for debug builds, we scan the sources on all regular make invokes
all-local:
- @for i in $(CSOURCES) $(HHEADERS); do @PERL@ $(top_srcdir)/lib/checksrc.pl $(top_srcdir)/lib/$$i; if test $$? != "0"; then exit 1; fi; done
+ @@PERL@ $(top_srcdir)/lib/checksrc.pl -D$(top_srcdir)/lib $(CSOURCES) $(HHEADERS)
endif