summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2011-04-20 22:44:38 +0200
committerDaniel Stenberg <daniel@haxx.se>2011-04-27 09:09:35 +0200
commit068d656c6db63a27967d3d2b13a0a801662ff174 (patch)
treec3af9efa5febc7a8d77c8d7328ede986d22eab8c /lib/Makefile.am
parent92f722017c084f1e13fb238e5c3ebfec78c0b70a (diff)
downloadcurl-068d656c6db63a27967d3d2b13a0a801662ff174.tar.gz
Makefile: run checksrc if debug enabled
And make the build fail if a warning or error was detected
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 7c24e5461..15dbcd290 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -185,5 +185,9 @@ $(VCPROJ): vc8proj.head vc8proj.foot Makefile.am
done; \
cat $(srcdir)/vc8proj.foot $(VCPROJOUT) )
+if CURLDEBUG
+# for debug builds, we scan the sources on all regular make invokes
all-local:
- @for i in $(CSOURCES) $(HHEADERS); do $(top_srcdir)/lib/checksrc.pl $(top_srcdir)/lib/$$i; done
+ @for i in $(CSOURCES) $(HHEADERS); do @PERL@ $(top_srcdir)/lib/checksrc.pl $(top_srcdir)/lib/$$i; if test $$? != "0"; then exit 1; fi; done
+endif
+