summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJakub Zakrzewski <jzakrzewski@e2ebridge.com>2014-08-22 17:02:59 +0200
committerDaniel Stenberg <daniel@haxx.se>2014-10-09 13:48:30 +0200
commita3154295c5b0b538d7883d30e6f1325b69bb50fd (patch)
tree4e7470637e55301850da87fe03ed55a48bcf7f3e /lib/CMakeLists.txt
parent2257deb50261e1e3193dd40ce92ae4f94ae135a1 (diff)
downloadcurl-a3154295c5b0b538d7883d30e6f1325b69bb50fd.tar.gz
Cmake: Got rid of setup_curl_dependencies
There is no need for such function. Include_directories propagate by themselves and having a function with one simple link statement makes little sense.
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index b2bcf0904..3ad62df1f 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -106,8 +106,6 @@ endif()
set_target_properties(${LIB_NAME} PROPERTIES COMPILE_DEFINITIONS BUILDING_LIBCURL)
-setup_curl_dependencies(${LIB_NAME})
-
# Remove the "lib" prefix since the library is already named "libcurl".
set_target_properties(${LIB_NAME} PROPERTIES PREFIX "")
set_target_properties(${LIB_NAME} PROPERTIES IMPORT_PREFIX "")