summaryrefslogtreecommitdiff
path: root/include/curl/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2019-03-14 10:40:38 +0100
committerDaniel Stenberg <daniel@haxx.se>2019-03-14 20:11:24 +0100
commit5cf5d57ab9f9d0878c2116d8407bf060616f9950 (patch)
tree4e9ac7036a0bdbea36035869d7721eeba9c15f14 /include/curl/Makefile.am
parent2af732f364e4734a5a5fd432c77a374e84e5d76c (diff)
downloadcurl-5cf5d57ab9f9d0878c2116d8407bf060616f9950.tar.gz
makefile: make checksrc and hugefile commands "silent"
... to match the style already used for compiling, linking etc. Acknowledges 'make V=1' to enable verbose. Closes #3681
Diffstat (limited to 'include/curl/Makefile.am')
-rw-r--r--include/curl/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/include/curl/Makefile.am b/include/curl/Makefile.am
index 16d97e1c4..a31f61b10 100644
--- a/include/curl/Makefile.am
+++ b/include/curl/Makefile.am
@@ -5,7 +5,7 @@
# | (__| |_| | _ <| |___
# \___|\___/|_| \_\_____|
#
-# Copyright (C) 1998 - 2018, Daniel Stenberg, <daniel@haxx.se>, et al.
+# Copyright (C) 1998 - 2019, Daniel Stenberg, <daniel@haxx.se>, et al.
#
# This software is licensed as described in the file COPYING, which
# you should have received as part of this distribution. The terms
@@ -25,8 +25,13 @@ pkginclude_HEADERS = \
pkgincludedir= $(includedir)/curl
+CHECKSRC = $(CS_$(V))
+CS_0 = @echo " RUN " $@;
+CS_1 =
+CS_ = $(CS_0)
+
checksrc:
- @@PERL@ $(top_srcdir)/lib/checksrc.pl -D$(top_srcdir)/include/curl $(pkginclude_HEADERS)
+ $(CHECKSRC)@PERL@ $(top_srcdir)/lib/checksrc.pl -D$(top_srcdir)/include/curl $(pkginclude_HEADERS)
if CURLDEBUG
# for debug builds, we scan the sources on all regular make invokes