summaryrefslogtreecommitdiff
path: root/include/curl/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2011-05-03 22:39:38 +0200
committerDaniel Stenberg <daniel@haxx.se>2011-05-09 10:20:31 +0200
commit2ef7a28a71f819343afefa721e5497119fb2cee0 (patch)
treebff97c0276a013d8ae31f0e48987291cdbcfcda5 /include/curl/Makefile.am
parent2a02c07a152ecc0d081e7f1a2c94dd8dc47ff7cf (diff)
downloadcurl-2ef7a28a71f819343afefa721e5497119fb2cee0.tar.gz
include: cleanup
Made the public headers checksrc compliant Removed types.h (it's been unused since April 2004) Made the root makefile do make in include by default as well, so that TAGS and the checksrc will work better.
Diffstat (limited to 'include/curl/Makefile.am')
-rw-r--r--include/curl/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/include/curl/Makefile.am b/include/curl/Makefile.am
index 5f5d5130c..86e8b7834 100644
--- a/include/curl/Makefile.am
+++ b/include/curl/Makefile.am
@@ -20,7 +20,7 @@
#
###########################################################################
pkginclude_HEADERS = \
- curl.h curlver.h easy.h mprintf.h stdcheaders.h types.h multi.h \
+ curl.h curlver.h easy.h mprintf.h stdcheaders.h multi.h \
typecheck-gcc.h curlbuild.h curlrules.h
pkgincludedir= $(includedir)/curl
@@ -44,3 +44,10 @@ EXTRA_DIST = curlbuild.h.in
DISTCLEANFILES = curlbuild.h
+checksrc:
+ @@PERL@ $(top_srcdir)/lib/checksrc.pl -Wcurlbuild.h -D$(top_srcdir)/include/curl $(pkginclude_HEADERS) $(EXTRA_DIST)
+
+if CURLDEBUG
+# for debug builds, we scan the sources on all regular make invokes
+all-local: checksrc
+endif