summaryrefslogtreecommitdiff
path: root/include/curl/Makefile.am
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2008-08-07 00:29:08 +0000
committerYang Tse <yangsita@gmail.com>2008-08-07 00:29:08 +0000
commit14240e9e109fe6af19438c6531d573f85dbb0b1e (patch)
tree61c5713bff289fbdc27e019b71427723bfb78dbc /include/curl/Makefile.am
parenta3045b4e4944a36f467f363607d6c6a50727fca2 (diff)
downloadcurl-14240e9e109fe6af19438c6531d573f85dbb0b1e.tar.gz
Initial support of curlbuild.h and curlrules.h which allows
to have a curl_off_t data type no longer gated to off_t.
Diffstat (limited to 'include/curl/Makefile.am')
-rw-r--r--include/curl/Makefile.am23
1 files changed, 21 insertions, 2 deletions
diff --git a/include/curl/Makefile.am b/include/curl/Makefile.am
index 707d1359f..bee5c25af 100644
--- a/include/curl/Makefile.am
+++ b/include/curl/Makefile.am
@@ -1,6 +1,25 @@
pkginclude_HEADERS = \
curl.h curlver.h easy.h mprintf.h stdcheaders.h types.h multi.h \
- typecheck-gcc.h
+ typecheck-gcc.h curlbuild.h curlrules.h
+
pkgincludedir= $(includedir)/curl
-CLEANFILES = *dist
+# curlbuild.h does not exist in the CVS tree. When the original libcurl
+# source code distribution archive file is created, curlbuild.h.dist is
+# renamed to curlbuild.h and included in the tarball so that it can be
+# used directly on non-configure systems.
+#
+# The distributed curlbuild.h will be overwritten on configure systems
+# when the configure script runs, with one that is suitable and specific
+# to the library being configured and built.
+#
+# curlbuild.h.in is the distributed template file from which the configure
+# script creates curlbuild.h at library configuration time, overwiting the
+# one included in the distribution archive.
+#
+# curlbuild.h.dist is not included in the source code distribution archive.
+
+EXTRA_DIST = curlbuild.h.in
+
+DISTCLEANFILES = curlbuild.h
+