summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJay Satiro <raysatiro@yahoo.com>2022-05-29 03:20:39 -0400
committerJay Satiro <raysatiro@yahoo.com>2022-06-01 01:58:43 -0400
commitfde966b69f0dc3b495121aeabef8a216661e8dae (patch)
tree39755eb3f5a236250cb5cce35fadd654117a7840 /configure.ac
parentc80f0aebbbffc565648ff936fe0f570b6be3b0d7 (diff)
downloadcurl-fde966b69f0dc3b495121aeabef8a216661e8dae.tar.gz
configure: skip libidn2 detection when winidn is used
Prior to this change --with-winidn could be overridden by libidn2 detection. Closes https://github.com/curl/curl/pull/8934
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac55
1 files changed, 30 insertions, 25 deletions
diff --git a/configure.ac b/configure.ac
index 32c67263b..3910ec631 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2445,31 +2445,36 @@ AC_ARG_WITH(libidn2,
AS_HELP_STRING([--with-libidn2=PATH],[Enable libidn2 usage])
AS_HELP_STRING([--without-libidn2],[Disable libidn2 usage]),
[OPT_IDN=$withval])
-case "$OPT_IDN" in
- no)
- dnl --without-libidn2 option used
- want_idn="no"
- AC_MSG_RESULT([no])
- ;;
- default)
- dnl configure option not specified
- want_idn="yes"
- want_idn_path="default"
- AC_MSG_RESULT([(assumed) yes])
- ;;
- yes)
- dnl --with-libidn2 option used without path
- want_idn="yes"
- want_idn_path="default"
- AC_MSG_RESULT([yes])
- ;;
- *)
- dnl --with-libidn2 option used with path
- want_idn="yes"
- want_idn_path="$withval"
- AC_MSG_RESULT([yes ($withval)])
- ;;
-esac
+if test "x$tst_links_winidn" = "xyes"; then
+ want_idn="no"
+ AC_MSG_RESULT([no (using winidn instead)])
+else
+ case "$OPT_IDN" in
+ no)
+ dnl --without-libidn2 option used
+ want_idn="no"
+ AC_MSG_RESULT([no])
+ ;;
+ default)
+ dnl configure option not specified
+ want_idn="yes"
+ want_idn_path="default"
+ AC_MSG_RESULT([(assumed) yes])
+ ;;
+ yes)
+ dnl --with-libidn2 option used without path
+ want_idn="yes"
+ want_idn_path="default"
+ AC_MSG_RESULT([yes])
+ ;;
+ *)
+ dnl --with-libidn2 option used with path
+ want_idn="yes"
+ want_idn_path="$withval"
+ AC_MSG_RESULT([yes ($withval)])
+ ;;
+ esac
+fi
if test "$want_idn" = "yes"; then
dnl idn library support has been requested