summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Eissing <stefan@eissing.org>2022-12-28 09:58:09 +0100
committerDaniel Stenberg <daniel@haxx.se>2022-12-28 13:30:05 +0100
commitf39472ea9f4f4e12cfbc0500c4580a8d52ce4a59 (patch)
tree2e5359992074730a175c86db5bfbfcbc173818ae /configure.ac
parent7fa449ca0c8ccccbb25a2f7023f09ae2184a78bb (diff)
downloadcurl-f39472ea9f4f4e12cfbc0500c4580a8d52ce4a59.tar.gz
openssl: remove attached easy handles from SSL instances
- keeping the "current" easy handle registered at SSL* is no longer necessary, since the "calling" data object is already stored in the cfilter's context (and used by other SSL backends from there). - The "detach" of an easy handle that goes out of scope is then avoided. - using SSL_set0_wbio for clear reference counting where available. Closes #10151
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d4fc183ed..479336f3c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4218,6 +4218,13 @@ if test "x$want_ech" != "xno"; then
fi
dnl *************************************************************
+dnl check whether OpenSSL (lookalikes) have SSL_set0_wbio
+dnl
+if test "x$OPENSSL_ENABLED" = "x1"; then
+ AC_CHECK_FUNCS([SSL_set0_wbio])
+fi
+
+dnl *************************************************************
dnl WebSockets
dnl
AC_MSG_CHECKING([whether to support WebSockets])