summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2023-03-03 14:49:21 +0100
committerDaniel Stenberg <daniel@haxx.se>2023-03-06 11:31:33 +0100
commite4d5685cb5d6eb07e1b43156fd7e3ba3563afba5 (patch)
tree3f112a2e19c57fea77793f572af432f7c3842090 /configure.ac
parent755ddbe901cd0c921fbc3ac5b3775c0dc683bc73 (diff)
downloadcurl-e4d5685cb5d6eb07e1b43156fd7e3ba3563afba5.tar.gz
DEPRECATE: the original legacy mingw version 1
Remove completely in September 2023 Closes #10667
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f40652c07..7154b9c61 100644
--- a/configure.ac
+++ b/configure.ac
@@ -612,6 +612,7 @@ case $host in
]])
],[
curl_mingw_original=yes
+ curl_mingw_die=yes
AC_MSG_RESULT([yes])
],[
AC_MSG_RESULT([no])
@@ -619,6 +620,18 @@ case $host in
;;
esac
+
+AC_ARG_WITH(mingw1-deprecated,dnl
+AS_HELP_STRING([--with-mingw1-deprecated],[confirm you realize support for mingw v1 is dying]),
+ if test X"$withval" != Xno; then
+ curl_mingw_die=
+ fi
+)
+
+if test -n "$curl_mingw_die"; then
+ AC_MSG_ERROR([support for mingw v1 is going away, enable temporarily with --with-mingw1-deprecated])
+fi
+
dnl **********************************************************************
dnl Compilation based checks should not be done before this point.
dnl **********************************************************************